No Man's Sky Bug Causes Ships To Shoot Themselves

Illustration for article titled iNo Mans Sky/i Bug Causes Ships To Shoot Themselvesem/em
Screenshot: No Man’s Sky (Hello Games)

In a game as big and complex as No Man’s Sky, some things are bound to go wrong. Some players in this vast virtual universe have been running into an unusual problem: their ships appear to be shooting themselves.

Advertisement

Players on the No Man’s Sky subreddit have been noting the bug since the release of Next, the latest update to the game. Some say that when they fire any weapons, their own ships take damage. “I shoot my photon cannon and it takes a chunk out of my health,” one player wrote in the thread linked above, “and when I shoot my rocket launcher I instantly die.” There have been dozens of complaints like this since the game updated. You can see the bug in action at about five and a half minutes into this clip:

“Our ships are procedurally generated, as are our weapon stats. The issue you mention affects a subset of ships that players can buy in-game, with certain weapons,” Sean Murray, founder of Hello Games, said over email when Kotaku asked about the bug. “It is generally only seen when multiplayer is active, and is related to network lag in these cases. The issue has been fixed by the team, is in testing, and will be released in a hotfix soon.”

Advertisement

While this seems pretty annoying if you’re on the run from pirates or being chased down by sentinels, Hello Games has been fixing bugs and releasing hotfix patches at a steady clip since the Next update. Hopefully this one get patched out soon so every player can have the Star Wars-y space battles they’ve been dreaming of.

Share This Story

Get our newsletter

DISCUSSION

acrosticacoustic
SaiyajinSeripa

this bug affects me on all my ships except my starter. i have 5 total. it’s really annoying to not be able to use any of my ships that have efficient launch thrusters or higher cargo capacities.

to be honest, while it’s clear that NMS is a good game at its core, i’m really disappointed that it’s in this state coming on 2 years since release. I know they’ve been adding tons and tons of content, and that multiplayer is something that’s inherently difficult to code and test, especially in a game like this... but I shouldn’t be getting multiple blue screens every play session. I shouldn’t be damaging myself when i fire. there shouldn’t be constant quest bugs — ranging from seeing strings like NPC_QUEST_MISSION_TEXT_RES instead of the actual mission text, to the quest getting confused about which resource it wants from me, to the quest simply disappearing, never to be seen again. there shouldn’t be a consistent sound buffer glitch every time i go to warp. and the framerate even on pro is just atrocious.

I appreciate that they’ve been adding so much content for free -- i just really wish they hadn’t compromised on stability and performance.