The recent DSi firmware slipped in anti-piracy measures that made it impossible to run R4-style carts. Days later, the firmware already appears to be cracked.

In this clip, the R4i appears to be apparently running on the latest DSi firmware, 1.4. That was quick! If this is true, don't worry Nintendo, there's always firmware 1.5.

Thanks, JY!