Thanks to Lucasart's refusal to acknowledge even the existence of games from a time when they made games that didn't suck, classic Lucas adventure games languish unsupported when running under more contemporary operating systems. Like Vista. Or...a GameCube. Thankfully, we've got ScummVM to help us out. The latest update was just released, and GameCube owners - as well as Wii owners - will be happy to know that the program is now fully supported on those platforms. There's also, for the first time, official support (as opposed to unofficial support) for the Wii Remote, so quit reading this and get busy flushing junk through time-travelling toilets. ScummVM [via Slashdot]